What’s Vulnerable › Vulnerabilities
CVE-2020-35934
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-01 · updated 2026-06-17
- Weakness: CWE-200
Description
The Advanced Access Manager plugin before 6.6.2 for WordPress displays the unfiltered user object (including all metadata) upon login via the REST API (aam/v1/authenticate or aam/v2/authenticate). This is a security problem if this object stores information that the user is not supposed to have (e.g., custom metadata added by a different plugin).
Affected products
- AAM Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More: before 6.6.2 — fixed in 6.6.2
How to fix
Upgrade to a fixed version: AAM Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More 6.6.2. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/blog/2020/08/high-severity-vulnerability-patched-in-advanced-access-manager/
- https://www.wordfence.com/blog/2020/08/high-severity-vulnerability-patched-in-advanced-access-manager/
Get alerted when CVE-2020-35934 or the next vulnerability affects your stack