What’s Vulnerable › Vulnerabilities
CVE-2020-35935
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-01 · updated 2026-06-17
Description
The Advanced Access Manager plugin before 6.6.2 for WordPress allows privilege escalation on profile updates via the aam_user_roles POST parameter if Multiple Role support is enabled. (The mechanism for deciding whether a user was entitled to add a role did not work in various custom-role scenarios.)
Affected products
- AAM Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More: before 6.6.2 — fixed in 6.6.2
How to fix
Upgrade to a fixed version: AAM Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More 6.6.2. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/blog/2020/08/high-severity-vulnerability-patched-in-advanced-access-manager/
- https://www.wordfence.com/blog/2020/08/high-severity-vulnerability-patched-in-advanced-access-manager/
Get alerted when CVE-2020-35935 or the next vulnerability affects your stack