What’s Vulnerable › Vulnerabilities
CVE-2020-35939
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-01 · updated 2026-06-17
- Weakness: CWE-502
Description
PHP Object injection vulnerabilities in the Team Showcase plugin before 1.22.16 for WordPress allow remote authenticated attackers to inject arbitrary PHP objects due to insecure unserialization of data supplied in a remotely hosted crafted payload in the source parameter via AJAX. The action must be set to team_import_xml_layouts.
Affected products
- pickplugins Post Grid: before 2.0.73 — fixed in 2.0.73
- PickPlugins Team Showcase: before 1.22.16 — fixed in 1.22.16
How to fix
Upgrade to a fixed version: pickplugins Post Grid 2.0.73; PickPlugins Team Showcase 1.22.16. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/blog/2020/10/high-severity-vulnerabilities-in-post-grid-and-team-showcase-plugins/
- https://www.wordfence.com/blog/2020/10/high-severity-vulnerabilities-in-post-grid-and-team-showcase-plugins/
Get alerted when CVE-2020-35939 or the next vulnerability affects your stack