What’s Vulnerable › Vulnerabilities
CVE-2020-35944
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-01 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in the PageLayer plugin before 1.1.2 for WordPress. The pagelayer_settings_page function is vulnerable to CSRF, which can lead to XSS.
Affected products
- softaculous Page Builder: Pagelayer – Drag and Drop website builder: before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: softaculous Page Builder: Pagelayer – Drag and Drop website builder 1.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/10240
- https://www.wordfence.com/blog/2020/05/high-severity-vulnerabilities-in-pagelayer-plugin-affect-over-200000-wordpress-sites/
- https://wpscan.com/vulnerability/10240
- https://www.wordfence.com/blog/2020/05/high-severity-vulnerabilities-in-pagelayer-plugin-affect-over-200000-wordpress-sites/
Get alerted when CVE-2020-35944 or the next vulnerability affects your stack