What’s Vulnerable › Vulnerabilities
CVE-2020-35945
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-01 · updated 2026-06-17
- Weakness: CWE-434
Description
An issue was discovered in the Divi Builder plugin, Divi theme, and Divi Extra theme before 4.5.3 for WordPress. Authenticated attackers, with contributor-level or above capabilities, can upload arbitrary files, including .php files. This occurs because the check for file extensions is on the client side.
Affected products
- Elegant Themes Divi: from 3.0 before 4.5.3 — fixed in 4.5.3
- Elegant Themes Divi Builder: from 2.0 before 4.5.3 — fixed in 4.5.3
- Elegantthemes Extra: from 2.0 before 4.5.3 — fixed in 4.5.3
How to fix
Upgrade to a fixed version: Elegant Themes Divi 4.5.3; Elegant Themes Divi Builder 4.5.3; Elegantthemes Extra 4.5.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/10342
- https://www.wordfence.com/blog/2020/08/critical-vulnerability-exposes-over-700000-sites-using-divi-extra-and-divi-builder/
- https://wpscan.com/vulnerability/10342
- https://www.wordfence.com/blog/2020/08/critical-vulnerability-exposes-over-700000-sites-using-divi-extra-and-divi-builder/
Get alerted when CVE-2020-35945 or the next vulnerability affects your stack