What’s Vulnerable › Vulnerabilities
CVE-2020-35952
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-03 · updated 2026-06-17
Description
login.php in PHPFusion (aka PHP-Fusion) Andromeda 9.x before 2020-12-30 generates error messages that distinguish between incorrect username and incorrect password (i.e., not a single "Incorrect username or password" message in both cases), which might allow enumeration.
Affected products
- PHP-Fusion: from 9.0 before 9.03.90 — fixed in 9.03.90
How to fix
Upgrade to a fixed version: PHP-Fusion 9.03.90. Check the vendor advisory for mitigations.
References
- https://github.com/PHPFusion/PHPFusion/issues/2346
- https://github.com/PHPFusion/PHPFusion/issues/2346
Get alerted when CVE-2020-35952 or the next vulnerability affects your stack