What’s Vulnerable › Vulnerabilities
CVE-2020-35963
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-03 · updated 2026-06-17
- Weakness: CWE-787
Description
flb_gzip_compress in flb_gzip.c in Fluent Bit before 1.6.4 has an out-of-bounds write because it does not use the correct calculation of the maximum gzip data-size expansion.
Affected products
- FluentBit Fluent Bit: before 1.6.4 — fixed in 1.6.4
How to fix
Upgrade to a fixed version: FluentBit Fluent Bit 1.6.4. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=27261
- https://fluentbit.io/announcements/v1.6.4/
- https://github.com/fluent/fluent-bit/commit/cadff53c093210404aed01c4cf586adb8caa07af
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=27261
- https://fluentbit.io/announcements/v1.6.4/
- https://github.com/fluent/fluent-bit/commit/cadff53c093210404aed01c4cf586adb8caa07af
Get alerted when CVE-2020-35963 or the next vulnerability affects your stack