What’s Vulnerable › Vulnerabilities
CVE-2020-35965
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-04 · updated 2026-06-17
- Weakness: CWE-787
Description
decode_frame in libavcodec/exr.c in FFmpeg 4.3.1 has an out-of-bounds write because of errors in calculations of when to perform memset zero operations.
Affected products
- Debian Linux: 9.0, 10.0
- FFmpeg: from 4.3.1 before 4.4 — fixed in 4.4
How to fix
Upgrade to a fixed version: FFmpeg 4.4. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=26532
- https://github.com/FFmpeg/FFmpeg/commit/3e5959b3457f7f1856d997261e6ac672bba49e8b
- https://github.com/FFmpeg/FFmpeg/commit/b0a8b40294ea212c1938348ff112ef1b9bf16bb3
- https://lists.debian.org/debian-lts-announce/2021/01/msg00026.html
- https://security.gentoo.org/glsa/202105-24
- https://www.debian.org/security/2021/dsa-4990
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=26532
- https://github.com/FFmpeg/FFmpeg/commit/3e5959b3457f7f1856d997261e6ac672bba49e8b
- https://github.com/FFmpeg/FFmpeg/commit/b0a8b40294ea212c1938348ff112ef1b9bf16bb3
- https://lists.debian.org/debian-lts-announce/2021/01/msg00026.html
- https://security.gentoo.org/glsa/202105-24
- https://www.debian.org/security/2021/dsa-4990
Get alerted when CVE-2020-35965 or the next vulnerability affects your stack