What’s Vulnerable › Vulnerabilities
CVE-2020-3599: Cisco Adaptive Security Appliance Software Web-Based Management Interface Reflected Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-21 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco Adaptive Security Appliance (ASA) Software could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the interface. This vulnerability exists because the web-based management interface does not properly validate user-supplied input. An attacker could exploit this vulnerability by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the interface or access sensitive, browser-based information.
Affected products
- Cisco Adaptive Security Appliance: before 9.6.4.45 — fixed in 9.6.4.45
- Cisco ASA Software: from 9.7.0 before 9.8.4.29; from 9.9.0 before 9.9.2.80; from 9.10.0 before 9.10.1.43; from 9.12.0 before 9.12.4.4; from 9.13.0 before 9.13.1.13; from 9.14.0 before 9.14.1.29 — fixed in 9.10.1.43, 9.12.4.4, 9.13.1.13, 9.14.1.29, 9.8.4.29, 9.9.2.80
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Appliance 9.6.4.45; Cisco ASA Software 9.10.1.43, 9.12.4.4, 9.13.1.13, 9.14.1.29. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-rxss-L54Htxp
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-rxss-L54Htxp
Get alerted when CVE-2020-3599 or the next vulnerability affects your stack