What’s Vulnerable › Vulnerabilities
CVE-2020-36155
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-04 · updated 2026-06-17
- Weakness: CWE-269
Description
An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Unauthenticated Privilege Escalation via User Meta. An attacker could supply an array parameter for sensitive metadata, such as the wp_capabilities user meta that defines a user's role. During the registration process, submitted registration details were passed to the update_profile function, and any metadata was accepted, e.g., wp_capabilities[administrator] for Administrator access.
Affected products
- ultimatemember Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership P: before 2.1.12 — fixed in 2.1.12
How to fix
Upgrade to a fixed version: ultimatemember Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership P 2.1.12. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/ultimate-member/#developers
- https://wpscan.com/vulnerability/cf13b0f8-5815-4d27-a276-5eff8985fc0b
- https://www.wordfence.com/blog/2020/11/critical-privilege-escalation-vulnerabilities-affect-100k-sites-using-ultimate-member-plugin/
- https://wordpress.org/plugins/ultimate-member/#developers
- https://wpscan.com/vulnerability/cf13b0f8-5815-4d27-a276-5eff8985fc0b
- https://www.wordfence.com/blog/2020/11/critical-privilege-escalation-vulnerabilities-affect-100k-sites-using-ultimate-member-plugin/
Get alerted when CVE-2020-36155 or the next vulnerability affects your stack