What’s Vulnerable › Vulnerabilities
CVE-2020-36157
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-04 · updated 2026-06-17
Description
An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Unauthenticated Privilege Escalation via User Roles. Due to the lack of filtering on the role parameter that could be supplied during the registration process, an attacker could supply the role parameter with a WordPress capability (or any custom Ultimate Member role) and effectively be granted those privileges.
Affected products
- ultimatemember Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership P: before 2.1.12 — fixed in 2.1.12
How to fix
Upgrade to a fixed version: ultimatemember Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership P 2.1.12. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/ultimate-member/#developers
- https://wpscan.com/vulnerability/33f059c5-58e5-44b9-bb27-793c3cedef3b
- https://www.wordfence.com/blog/2020/11/critical-privilege-escalation-vulnerabilities-affect-100k-sites-using-ultimate-member-plugin/
- https://wordpress.org/plugins/ultimate-member/#developers
- https://wpscan.com/vulnerability/33f059c5-58e5-44b9-bb27-793c3cedef3b
- https://www.wordfence.com/blog/2020/11/critical-privilege-escalation-vulnerabilities-affect-100k-sites-using-ultimate-member-plugin/
Get alerted when CVE-2020-36157 or the next vulnerability affects your stack