What’s Vulnerable › Vulnerabilities
CVE-2020-36190
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-12 · updated 2026-06-17
- Weakness: CWE-79
Description
RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
Affected products
- https://github.com/sferik rails_admin ruby gem: before 1.4.3; from 2.0.0 before 2.0.2 — fixed in 1.4.3, 2.0.2
How to fix
Upgrade to a fixed version: https://github.com/sferik rails_admin ruby gem 1.4.3, 2.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/sferik/rails_admin/blob/master/README.md
- https://github.com/sferik/rails_admin/commit/d72090ec6a07c3b9b7b48ab50f3d405f91ff4375
- https://github.com/sferik/rails_admin/compare/v1.4.2...v1.4.3
- https://github.com/sferik/rails_admin/blob/master/README.md
- https://github.com/sferik/rails_admin/commit/d72090ec6a07c3b9b7b48ab50f3d405f91ff4375
- https://github.com/sferik/rails_admin/compare/v1.4.2...v1.4.3
Get alerted when CVE-2020-36190 or the next vulnerability affects your stack