What’s Vulnerable › Vulnerabilities

CVE-2020-36194: XSS Vulnerability in QTS and QuTS heroCommand Injection Vulnerabilities in QTS and QuTS hero

Description

An XSS vulnerability has been reported to affect QNAP NAS running QTS and QuTS hero. If exploited, this vulnerability allows attackers to inject malicious code. This issue affects: QNAP Systems Inc. QTS versions prior to 4.5.2.1566 Build 20210202. QNAP Systems Inc. QuTS hero versions prior to h4.5.2.1638 build 20210414. This issue does not affect: QNAP Systems Inc. QTS 4.5.3.

Affected products

How to fix

Upgrade to a fixed version: QNAP QTS 4.5.2.1566; QNAP Systems Inc. QuTS hero h4.5.2.1638. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-36194 or the next vulnerability affects your stack