What’s Vulnerable › Vulnerabilities
CVE-2020-36213
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-26 · updated 2026-06-17
Description
An issue was discovered in the abi_stable crate before 0.9.1 for Rust. A retain call can create an invalid UTF-8 string, violating soundness.
Affected products
- Abi Stable Project Abi Stable: before 0.9.1 — fixed in 0.9.1
How to fix
Upgrade to a fixed version: Abi Stable Project Abi Stable 0.9.1. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2020-0105.html
- https://rustsec.org/advisories/RUSTSEC-2020-0105.html
Get alerted when CVE-2020-36213 or the next vulnerability affects your stack