What’s Vulnerable › Vulnerabilities
CVE-2020-36218
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-26 · updated 2026-06-17
Description
An issue was discovered in the buttplug crate before 1.0.4 for Rust. ButtplugFutureStateShared does not properly consider (!Send|!Sync) objects, leading to a data race.
Affected products
- Nonpolynomial Buttplug: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: Nonpolynomial Buttplug 1.0.4. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2020-0112.html
- https://rustsec.org/advisories/RUSTSEC-2020-0112.html
Get alerted when CVE-2020-36218 or the next vulnerability affects your stack