What’s Vulnerable › Vulnerabilities
CVE-2020-36282
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-12 · updated 2026-06-17
- Weakness: CWE-502
Description
JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data.
Affected products
- rabbitmq Jms Client: from 1.0.0 before 1.15.2; from 2.0.0 before 2.2.0 — fixed in 1.15.2, 2.2.0
How to fix
Upgrade to a fixed version: rabbitmq Jms Client 1.15.2, 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-jms-client/issues/135
- https://github.com/rabbitmq/rabbitmq-jms-client/releases/tag/v1.15.2
- https://github.com/rabbitmq/rabbitmq-jms-client/releases/tag/v2.2.0
- https://medium.com/%40ramon93i7/a99645d0448b
- https://github.com/rabbitmq/rabbitmq-jms-client/issues/135
- https://github.com/rabbitmq/rabbitmq-jms-client/releases/tag/v1.15.2
- https://github.com/rabbitmq/rabbitmq-jms-client/releases/tag/v2.2.0
- https://medium.com/%40ramon93i7/a99645d0448b
Get alerted when CVE-2020-36282 or the next vulnerability affects your stack