What’s Vulnerable › Vulnerabilities
CVE-2020-36290
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Livesearch macro in Confluence Server and Data Center before version 7.4.5, from version 7.5.0 before 7.6.3, and from version 7.7.0 before version 7.7.4 allows remote attackers with permission to edit a page or blog to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability in the page excerpt functionality.
Affected products
- Atlassian Confluence Data Center: before 7.4.5; from 7.5.0 before 7.6.3; from 7.7.0 before 7.7.4 — fixed in 7.4.5, 7.6.3, 7.7.4
- Atlassian Confluence Data Center: before 7.4.5; from 7.5.0 before 7.6.3; from 7.7.0 before 7.7.4 — fixed in 7.4.5, 7.6.3, 7.7.4
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.4.5, 7.6.3, 7.7.4; Atlassian Confluence Data Center 7.4.5, 7.6.3, 7.7.4. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-60118
- https://jira.atlassian.com/browse/CONFSERVER-60118
Get alerted when CVE-2020-36290 or the next vulnerability affects your stack