What’s Vulnerable › Vulnerabilities
CVE-2020-36311
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-07 · updated 2026-10-08
Description
An issue was discovered in the Linux kernel before 5.9. arch/x86/kvm/svm/sev.c allows attackers to cause a denial of service (soft lockup) by triggering destruction of a large SEV VM (which requires unregistering many encrypted regions), aka CID-7be74942f184.
Affected products
- Debian Linux: 9.0, 10.0
- Linux kernel: before 5.9.0 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: Linux kernel 5.9.0. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.9
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=7be74942f184fdfba34ddd19a0d995deb34d4a03
- https://lists.debian.org/debian-lts-announce/2021/07/msg00015.html
- https://www.debian.org/security/2021/dsa-4941
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.9
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=7be74942f184fdfba34ddd19a0d995deb34d4a03
- https://lists.debian.org/debian-lts-announce/2021/07/msg00015.html
- https://www.debian.org/security/2021/dsa-4941
Get alerted when CVE-2020-36311 or the next vulnerability affects your stack