What’s Vulnerable › Vulnerabilities
CVE-2020-36317
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-11 · updated 2026-06-17
- Weakness: CWE-787
Description
In the standard library in Rust before 1.49.0, String::retain() function has a panic safety problem. It allows creation of a non-UTF-8 Rust string when the provided closure panics. This bug could result in a memory safety violation when other string APIs assume that UTF-8 encoding is used on the same string.
Affected products
- rust-lang rust: before 1.49.0 — fixed in 1.49.0
How to fix
Upgrade to a fixed version: rust-lang rust 1.49.0. Check the vendor advisory for mitigations.
References
- https://github.com/rust-lang/rust/issues/78498
- https://github.com/rust-lang/rust/pull/78499
- https://github.com/rust-lang/rust/issues/78498
- https://github.com/rust-lang/rust/pull/78499
Get alerted when CVE-2020-36317 or the next vulnerability affects your stack