What’s Vulnerable › Vulnerabilities
CVE-2020-36318
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-11 · updated 2026-06-17
- Weakness: CWE-415
Description
In the standard library in Rust before 1.49.0, VecDeque::make_contiguous has a bug that pops the same element more than once under certain condition. This bug could result in a use-after-free or double free.
Affected products
- rust-lang rust: from 1.48.0 before 1.49.0 — fixed in 1.49.0
How to fix
Upgrade to a fixed version: rust-lang rust 1.49.0. Check the vendor advisory for mitigations.
References
- https://github.com/rust-lang/rust/issues/79808
- https://github.com/rust-lang/rust/pull/79814
- https://github.com/rust-lang/rust/issues/79808
- https://github.com/rust-lang/rust/pull/79814
Get alerted when CVE-2020-36318 or the next vulnerability affects your stack