What’s Vulnerable › Vulnerabilities

CVE-2020-36319: Potential sensitive data exposure in applications using Vaadin 15

Description

Insecure configuration of default ObjectMapper in com.vaadin:flow-server versions 3.0.0 through 3.0.5 (Vaadin 15.0.0 through 15.0.4) may expose sensitive data if the application also uses e.g. @RestController

Affected products

How to fix

Upgrade to a fixed version: vaadin flow 3.0.6; Vaadin 15.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-36319 or the next vulnerability affects your stack