What’s Vulnerable › Vulnerabilities
CVE-2020-36327
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-29 · updated 2026-10-08
Description
Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.16 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application. NOTE: it is not correct to use CVE-2021-24105 for every "Dependency Confusion" issue in every product.
Affected products
- rubygem-bundler: from 1.16.0 before 2.2.10; from 2.2.11 through 2.2.16 — fixed in 2.2.10
- Fedoraproject Fedora: 34
- Microsoft Package Manager Configurations: all versions
How to fix
Upgrade to a fixed version: rubygem-bundler 2.2.10. Check the vendor advisory for mitigations.
References
- https://bundler.io/blog/2021/02/15/a-more-secure-bundler-we-fixed-our-source-priorities.html
- https://github.com/rubygems/rubygems/issues/3982
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MWXHK5UUHVSHF7HTHMX6JY3WXDVNIHSL/
- https://mensfeld.pl/2021/02/rubygems-dependency-confusion-attack-side-of-things/
- https://msrc.microsoft.com/update-guide/en-US/vulnerability/CVE-2021-24105
- https://www.zofrex.com/blog/2021/04/29/bundler-still-vulnerable-dependency-confusion-cve-2020-36327/
- https://bundler.io/blog/2021/02/15/a-more-secure-bundler-we-fixed-our-source-priorities.html
- https://github.com/rubygems/rubygems/issues/3982
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MWXHK5UUHVSHF7HTHMX6JY3WXDVNIHSL/
- https://mensfeld.pl/2021/02/rubygems-dependency-confusion-attack-side-of-things/
- https://msrc.microsoft.com/update-guide/en-US/vulnerability/CVE-2021-24105
- https://www.zofrex.com/blog/2021/04/29/bundler-still-vulnerable-dependency-confusion-cve-2020-36327/
Get alerted when CVE-2020-36327 or the next vulnerability affects your stack