What’s Vulnerable › Vulnerabilities
CVE-2020-36389
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-17 · updated 2026-06-17
- Weakness: CWE-352
Description
In CiviCRM before 5.28.1 and CiviCRM ESR before 5.27.5 ESR, the CKEditor configuration form allows CSRF.
Affected products
- CiviCRM: before 5.27.5; before 5.28.1 — fixed in 5.27.5, 5.28.1
How to fix
Upgrade to a fixed version: CiviCRM 5.27.5, 5.28.1. Check the vendor advisory for mitigations.
References
- https://blog.sonarsource.com/civicrm-code-execution-vulnerability-chain-explained/
- https://civicrm.org/advisory/civi-sa-2020-11-csrf-ckeditor-configuration-form
- https://blog.sonarsource.com/civicrm-code-execution-vulnerability-chain-explained/
- https://civicrm.org/advisory/civi-sa-2020-11-csrf-ckeditor-configuration-form
Get alerted when CVE-2020-36389 or the next vulnerability affects your stack