What’s Vulnerable › Vulnerabilities
CVE-2020-36429
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-20 · updated 2026-06-17
- Weakness: CWE-787
Description
Variant_encodeJson in open62541 1.x before 1.0.4 has an out-of-bounds write for a large recursion depth.
Affected products
- open62541: from 1.0.0 before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: open62541 1.0.4. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=20578
- https://github.com/google/oss-fuzz-vulns/blob/main/vulns/open62541/OSV-2020-153.yaml
- https://github.com/open62541/open62541/commit/c800e2987b10bb3af6ef644b515b5d6392f8861d
- https://github.com/open62541/open62541/compare/v1.0.3...v1.0.4
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=20578
- https://github.com/google/oss-fuzz-vulns/blob/main/vulns/open62541/OSV-2020-153.yaml
- https://github.com/open62541/open62541/commit/c800e2987b10bb3af6ef644b515b5d6392f8861d
- https://github.com/open62541/open62541/compare/v1.0.3...v1.0.4
Get alerted when CVE-2020-36429 or the next vulnerability affects your stack