What’s Vulnerable › Vulnerabilities
CVE-2020-36443
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-08 · updated 2026-06-17
- Weakness: CWE-908
Description
An issue was discovered in the libp2p-deflate crate before 0.27.1 for Rust. An uninitialized buffer is passed to AsyncRead::poll_read(), which is a user-provided trait function.
Affected products
- Libp2P-Deflate: before 0.27.1 — fixed in 0.27.1
How to fix
Upgrade to a fixed version: Libp2P-Deflate 0.27.1. Check the vendor advisory for mitigations.
References
- https://raw.githubusercontent.com/rustsec/advisory-db/main/crates/libp2p-deflate/RUSTSEC-2020-0123.md
- https://rustsec.org/advisories/RUSTSEC-2020-0123.html
- https://raw.githubusercontent.com/rustsec/advisory-db/main/crates/libp2p-deflate/RUSTSEC-2020-0123.md
- https://rustsec.org/advisories/RUSTSEC-2020-0123.html
Get alerted when CVE-2020-36443 or the next vulnerability affects your stack