What’s Vulnerable › Vulnerabilities
CVE-2020-36599: OmniAuth's `lib/omniauth/failure_endpoint.rb` does not escape `message_key` value
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-18 · updated 2026-06-17
- Weakness: CWE-116
Description
lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
Affected products
- omniauth ruby gem: before 1.9.2; 2.0.0-pre.rc1 — fixed in 1.9.2
- Rubygems Omniauth: before 1.9.2; from 2.0.0.pre.rc1 before 2.0.0; 0.0.1, 0.0.3, 0.0.4, 0.0.5, 0.1.0, 0.1.1 (+53) — fixed in 1.9.2, 2.0.0
How to fix
Upgrade to a fixed version: omniauth ruby gem 1.9.2; Rubygems Omniauth 1.9.2, 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/omniauth/omniauth/commit/43a396f181ef7d0ed2ec8291c939c95e3ed3ff00#diff-575abda9deb9b1a77bf534e898a923029b9a61e991d626db88dc6e8b34260aa2
- https://rubygems.org/gems/omniauth/versions/1.9.2
- https://github.com/omniauth/omniauth/commit/43a396f181ef7d0ed2ec8291c939c95e3ed3ff00#diff-575abda9deb9b1a77bf534e898a923029b9a61e991d626db88dc6e8b34260aa2
- https://rubygems.org/gems/omniauth/versions/1.9.2
Get alerted when CVE-2020-36599 or the next vulnerability affects your stack