What’s Vulnerable › Vulnerabilities
CVE-2020-36635: OpenMRS Appointment Scheduling Module AppointmentTypeValidator.java validateFieldName cross site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in OpenMRS Appointment Scheduling Module up to 1.12.x. It has been classified as problematic. This affects the function validateFieldName of the file api/src/main/java/org/openmrs/module/appointmentscheduling/validator/AppointmentTypeValidator.java. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 1.13.0 is able to address this issue. The name of the patch is 34213c3f6ea22df427573076fb62744694f601d8. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216915.
Affected products
- OpenMRS Appointment Scheduling Module: before 1.13.0 — fixed in 1.13.0
How to fix
Upgrade to a fixed version: OpenMRS Appointment Scheduling Module 1.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/openmrs/openmrs-module-appointmentscheduling/commit/34213c3f6ea22df427573076fb62744694f601d8
- https://github.com/openmrs/openmrs-module-appointmentscheduling/pull/32
- https://github.com/openmrs/openmrs-module-appointmentscheduling/releases/tag/1.13.0
- https://vuldb.com/?ctiid.216915
- https://vuldb.com/?id.216915
- https://github.com/openmrs/openmrs-module-appointmentscheduling/commit/34213c3f6ea22df427573076fb62744694f601d8
- https://github.com/openmrs/openmrs-module-appointmentscheduling/pull/32
- https://github.com/openmrs/openmrs-module-appointmentscheduling/releases/tag/1.13.0
- https://vuldb.com/?ctiid.216915
- https://vuldb.com/?id.216915
Get alerted when CVE-2020-36635 or the next vulnerability affects your stack