What’s Vulnerable › Vulnerabilities
CVE-2020-36636: OpenMRS Admin UI Module Account Setup AccountPageController.java sendErrorMessage cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability classified as problematic has been found in OpenMRS Admin UI Module up to 1.4.x. Affected is the function sendErrorMessage of the file omod/src/main/java/org/openmrs/module/adminui/page/controller/systemadmin/accounts/AccountPageController.java of the component Account Setup Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 702fbfdac7c4418f23bb5f6452482b4a88020061. It is recommended to upgrade the affected component. VDB-216918 is the identifier assigned to this vulnerability.
Affected products
- OpenMRS Admin UI Module: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: OpenMRS Admin UI Module 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/openmrs/openmrs-module-adminui/commit/702fbfdac7c4418f23bb5f6452482b4a88020061
- https://github.com/openmrs/openmrs-module-adminui/pull/57
- https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.5.0
- https://vuldb.com/?ctiid.216918
- https://vuldb.com/?id.216918
- https://github.com/openmrs/openmrs-module-adminui/commit/702fbfdac7c4418f23bb5f6452482b4a88020061
- https://github.com/openmrs/openmrs-module-adminui/pull/57
- https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.5.0
- https://vuldb.com/?ctiid.216918
- https://vuldb.com/?id.216918
Get alerted when CVE-2020-36636 or the next vulnerability affects your stack