What’s Vulnerable › Vulnerabilities
CVE-2020-36652: File and Directory Permissions Vulnerability in Hitachi Automation Director, Hitachi Infrastructure Analytics Advisor, Hitachi Ops Center
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-28 · updated 2026-06-17
- Weakness: CWE-276
Description
Incorrect Default Permissions vulnerability in Hitachi Automation Director on Linux, Hitachi Infrastructure Analytics Advisor on Linux (Hitachi Infrastructure Analytics Advisor, Analytics probe server components), Hitachi Ops Center Automator on Linux, Hitachi Ops Center Analyzer on Linux (Hitachi Ops Center Analyzer, Analyzer probe server components), Hitachi Ops Center Viewpoint on Linux (Viewpoint RAID Agent component) allows local users to read and write specific files. This issue affects Hitachi Automation Director: from 8.2.0-00 through 10.6.1-00; Hitachi Infrastructure Analytics Advisor: from 2.0.0-00 through 4.0.0-00; Hitachi Ops Center Automator: before 10.9.1-00; Hitachi Ops Center Analyzer: before 10.9.1-00; Hitachi Ops Center Viewpoint: before 10.9.1-00.
Affected products
- Hitachi Automation Director: from 8.2.0-00 through 10.6.1-00
- Hitachi Infrastructure Analytics Advisor: from 2.0.0-00 through 4.0.0-00
- Hitachi Ops Center Analyzer: before 10.9.1-00 — fixed in 10.9.1-00
- Hitachi Ops Center Automator: before 10.9.1-00 — fixed in 10.9.1-00
- Hitachi Ops Center Viewpoint: before 10.9.1-00 — fixed in 10.9.1-00
How to fix
Upgrade to a fixed version: Hitachi Ops Center Analyzer 10.9.1-00; Hitachi Ops Center Automator 10.9.1-00; Hitachi Ops Center Viewpoint 10.9.1-00. Check the vendor advisory for mitigations.
References
- https://www.hitachi.com/products/it/software/security/info/vuls/hitachi-sec-2023-106/index.html
- https://www.hitachi.com/products/it/software/security/info/vuls/hitachi-sec-2023-106/index.html
Get alerted when CVE-2020-36652 or the next vulnerability affects your stack