What’s Vulnerable › Vulnerabilities
CVE-2020-36655
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-21 · updated 2026-06-17
- Weakness: CWE-94
Description
Yii Yii2 Gii before 2.2.2 allows remote attackers to execute arbitrary code via the Generator.php messageCategory field. The attacker can embed arbitrary PHP code into the model file.
Affected products
- yiiframework Gii: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: yiiframework Gii 2.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/yiisoft/yii2-gii/issues/433
- https://lab.wallarm.com/yii2-gii-remote-code-execution/
- https://github.com/yiisoft/yii2-gii/issues/433
- https://lab.wallarm.com/yii2-gii-remote-code-execution/
Get alerted when CVE-2020-36655 or the next vulnerability affects your stack