What’s Vulnerable › Vulnerabilities
CVE-2020-36658
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-27 · updated 2026-06-17
- Weakness: CWE-295
Description
In Apache::Session::LDAP before 0.5, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used. NOTE: this can, for example, be fixed in conjunction with the CVE-2020-16093 fix.
Affected products
- Debian Linux: 10.0
- lemonldap-ng Apache::Session::Ldap: before 0.5 — fixed in 0.5
How to fix
Upgrade to a fixed version: lemonldap-ng Apache::Session::Ldap 0.5. Check the vendor advisory for mitigations.
References
- https://github.com/LemonLDAPNG/Apache-Session-LDAP/commit/490722b71eed1ed1ab33d58c78578f23e043561f
- https://lists.debian.org/debian-lts-announce/2023/01/msg00024.html
- https://github.com/LemonLDAPNG/Apache-Session-LDAP/commit/490722b71eed1ed1ab33d58c78578f23e043561f
- https://lists.debian.org/debian-lts-announce/2023/01/msg00024.html
Get alerted when CVE-2020-36658 or the next vulnerability affects your stack