What’s Vulnerable › Vulnerabilities
CVE-2020-36659
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-27 · updated 2026-06-17
- Weakness: CWE-295
Description
In Apache::Session::Browseable before 1.3.6, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used. NOTE: this can, for example, be fixed in conjunction with the CVE-2020-16093 fix.
Affected products
- Debian Linux: 10.0
- lemonldap-ng Apache::Session::Browsable: before 1.3.6 — fixed in 1.3.6
How to fix
Upgrade to a fixed version: lemonldap-ng Apache::Session::Browsable 1.3.6. Check the vendor advisory for mitigations.
References
- https://github.com/LemonLDAPNG/Apache-Session-Browseable/commit/fdf393235140b293cae5578ef136055a78f3574f
- https://lists.debian.org/debian-lts-announce/2023/01/msg00025.html
- https://github.com/LemonLDAPNG/Apache-Session-Browseable/commit/fdf393235140b293cae5578ef136055a78f3574f
- https://lists.debian.org/debian-lts-announce/2023/01/msg00025.html
Get alerted when CVE-2020-36659 or the next vulnerability affects your stack