What’s Vulnerable › Vulnerabilities
CVE-2020-36691
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-24 · updated 2026-06-17
- Weakness: CWE-674
Description
An issue was discovered in the Linux kernel before 5.8. lib/nlattr.c allows attackers to cause a denial of service (unbounded recursion) via a nested Netlink policy with a back reference.
Affected products
- Linux kernel: before 5.8 — fixed in 5.8
How to fix
Upgrade to a fixed version: Linux kernel 5.8. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.8
- https://github.com/torvalds/linux/commit/7690aa1cdf7c4565ad6b013b324c28b685505e24
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.8
- https://github.com/torvalds/linux/commit/7690aa1cdf7c4565ad6b013b324c28b685505e24
Get alerted when CVE-2020-36691 or the next vulnerability affects your stack