What’s Vulnerable › Vulnerabilities

CVE-2020-36708: Epsilon Framework Themes (Various Versions) - Function Injection

Description

The following themes for WordPress are vulnerable to Function Injections in versions up to and including Shapely <= 1.2.7, NewsMag <= 2.4.1, Activello <= 1.4.0, Illdy <= 2.1.4, Allegiant <= 1.2.2, Newspaper X <= 1.3.1, Pixova Lite <= 2.0.5, Brilliance <= 1.2.7, MedZone Lite <= 1.2.4, Regina Lite <= 2.0.4, Transcend <= 1.1.8, Affluent <= 1.1.0, Bonkers <= 1.0.4, Antreas <= 1.0.2, Sparkling <= 2.4.8, and NatureMag Lite <= 1.0.4. This is due to epsilon_framework_ajax_action. This makes it possible for unauthenticated attackers to call functions and achieve remote code execution.

Affected products

How to fix

Upgrade to a fixed version: Silkalns Activello 1.4.2; silkalns Bonkers 1.0.6; silkalns Illdy 2.1.7; silkalns Newspaper X 1.3.2; silkalns Pixova Lite 2.0.7; silkalns Shapely 1.2.9; Cpothemes Affluent 1.1.2; WP Chill Allegiant 1.2.6; Cpothemes Brilliance 1.3.0; Cpothemes Transcend 1.2.0; machothemes Antreas 1.0.7; machothemes MedZone Lite 1.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-36708 or the next vulnerability affects your stack