What’s Vulnerable › Vulnerabilities
CVE-2020-36709: Page Builder: KingComposer < 2.9.4 - Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Builder: KingComposer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via via shortcode in versions before 2.9.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- kingthemes Page Builder: KingComposer – Free Drag and Drop page builder by King-Theme: before 2.9.4 — fixed in 2.9.4
How to fix
Upgrade to a fixed version: kingthemes Page Builder: KingComposer – Free Drag and Drop page builder by King-Theme 2.9.4. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/wordpress-kingcomposer-page-builder-fixed-multiple-critical-vulnerabilities/
- https://wpsocket.com/plugin/kingcomposer/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6447de64-b484-4f64-ad78-7df81b5a0ed7?source=cve
- https://blog.nintechnet.com/wordpress-kingcomposer-page-builder-fixed-multiple-critical-vulnerabilities/
- https://wpsocket.com/plugin/kingcomposer/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6447de64-b484-4f64-ad78-7df81b5a0ed7?source=cve
Get alerted when CVE-2020-36709 or the next vulnerability affects your stack