What’s Vulnerable › Vulnerabilities
CVE-2020-36828: DiscuzX install_function.php show_next_step cross site scripting
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in DiscuzX up to 3.4-20200818. It has been classified as problematic. Affected is the function show_next_step of the file upload/install/include/install_function.php. The manipulation of the argument uchidden leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 3.4-20210119 is able to address this issue. The name of the patch is 4a9673624f46f7609486778ded9653733020c567. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-258612.
Affected products
- DiscuzX: 3.4-20200818
References
- https://github.com/codersclub/DiscuzX/commit/4a9673624f46f7609486778ded9653733020c567
- https://vuldb.com/?ctiid.258612
- https://vuldb.com/?id.258612
- https://github.com/codersclub/DiscuzX/commit/4a9673624f46f7609486778ded9653733020c567
- https://vuldb.com/?ctiid.258612
- https://vuldb.com/?id.258612
Get alerted when CVE-2020-36828 or the next vulnerability affects your stack