What’s Vulnerable › Vulnerabilities
CVE-2020-36829
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-08 · updated 2026-06-17
Description
The Mojolicious module before 8.65 for Perl is vulnerable to secure_compare timing attacks that allow an attacker to guess the length of a secret string. Only versions after 1.74 are affected.
Affected products
- SRI Mojolicious: before 8.65 — fixed in 8.65
How to fix
Upgrade to a fixed version: SRI Mojolicious 8.65. Check the vendor advisory for mitigations.
References
- https://github.com/mojolicious/mojo/issues/1599
- https://github.com/mojolicious/mojo/pull/1601
- https://lists.debian.org/debian-lts-announce/2024/06/msg00025.html
- https://github.com/mojolicious/mojo/issues/1599
- https://github.com/mojolicious/mojo/pull/1601
- https://lists.debian.org/debian-lts-announce/2024/06/msg00025.html
Get alerted when CVE-2020-36829 or the next vulnerability affects your stack