What’s Vulnerable › Vulnerabilities
CVE-2020-36831: NextScripts: Social Networks Auto-Poster <= 4.3.17 - Missing Authorization
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-284
Description
The NextScripts: Social Networks Auto-Poster plugin for WordPress is vulnerable to authorization bypass due to missing capability checks on multiple user privilege/security functions provided in versions up to, and including 4.3.17. This makes it possible for low-privileged attackers, like subscribers, to perform restricted actions that would be otherwise locked to a administrative-level user.
Affected products
- NextScripts: Social Networks Auto-Poster: before 4.3.18 — fixed in 4.3.18
How to fix
Upgrade to a fixed version: NextScripts: Social Networks Auto-Poster 4.3.18. Check the vendor advisory for mitigations.
References
- https://blog.sucuri.net/2020/09/insufficient-privilege-validation-in-nextscripts-social-networks-auto-poster.html
- https://wpscan.com/vulnerability/0641578b-16b9-4d79-af69-b4886840da36
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-nextscripts-social-networks-auto-poster-security-bypass-4-3-17/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3709465d-6d67-45bd-abb9-4875065b8129?source=cve
Get alerted when CVE-2020-36831 or the next vulnerability affects your stack