What’s Vulnerable › Vulnerabilities
CVE-2020-36841: WooCommerce Smart Coupons <= 4.6.0 - Unauthenticated Coupon Creation
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-285
Description
The WooCommerce Smart Coupons plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the woocommerce_coupon_admin_init function in versions up to, and including, 4.6.0. This makes it possible for unauthenticated attackers to send themselves gift certificates of any value, which could be redeemed for products sold on the victim’s storefront.
Affected products
- WooCommerce Smart Coupons: before 4.6.5 — fixed in 4.6.5
How to fix
Upgrade to a fixed version: WooCommerce Smart Coupons 4.6.5. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/blog/2020/03/coupon-creation-vulnerability-patched-in-woocommerce-smart-coupons/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/eeeb03f7-5f78-4462-b0b4-5080bbc419a3?source=cve
Get alerted when CVE-2020-36841 or the next vulnerability affects your stack