What’s Vulnerable › Vulnerabilities
CVE-2020-36846: IO::Compress::Brotli versions prior to 0.007 for Perl have an integer overflow in the bundled Brotli C library
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-1395
Description
A buffer overflow, as described in CVE-2020-8927, exists in the embedded Brotli library. Versions of IO::Compress::Brotli prior to 0.007 included a version of the brotli library prior to version 1.0.8, where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your IO::Compress::Brotli module to 0.007 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
Affected products
- TIMLEGGE IO::Compress::Brotli: before 0.007 — fixed in 0.007
How to fix
Upgrade to a fixed version: TIMLEGGE IO::Compress::Brotli 0.007. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-5v8v-66v8-mwm7
- https://github.com/google/brotli/commit/223d80cfbec8fd346e32906c732c8ede21f0cea6
- https://github.com/google/brotli/pull/826
- https://github.com/timlegge/perl-IO-Compress-Brotli/blob/8b44c83b23bb4658179e1494af4b725a1bc476bc/Changes#L52
- https://nvd.nist.gov/vuln/detail/CVE-2020-8927
Get alerted when CVE-2020-36846 or the next vulnerability affects your stack