What’s Vulnerable › Vulnerabilities
CVE-2020-36847: Simple File List < 4.2.3 - Remote Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 43.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-12 · updated 2026-06-17
- Weakness: CWE-434
Description
The Simple-File-List Plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 4.2.2 via the rename function which can be used to rename uploaded PHP code with a png extension to use a php extension. This allows unauthenticated attackers to execute code on the server.
Affected products
- Mitchell Bennis Simple File List: before 4.2.3 — fixed in 4.2.3
How to fix
Upgrade to a fixed version: Mitchell Bennis Simple File List 4.2.3. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/160221/
- https://plugins.trac.wordpress.org/changeset/2286920/simple-file-list
- https://wpscan.com/vulnerability/365da9c5-a8d0-45f6-863c-1b1926ffd574/
- https://www.cybersecurity-help.cz/vdb/SB2020042711
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9eb835fd-6ebf-4162-856c-0366b663a07e?source=cve
- https://wpscan.com/vulnerability/365da9c5-a8d0-45f6-863c-1b1926ffd574/
Get alerted when CVE-2020-36847 or the next vulnerability affects your stack