What’s Vulnerable › Vulnerabilities
CVE-2020-36854: Async JavaScript <= 2.19.07.14 - Authenticated (Subscriber+) Stored Cross-Site Scripting
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Async JavaScript plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.19.07.14. This is due to missing authorization checks on the aj_steps AJAX aciton along with a lack on sanitization on the settings saved via the function. This makes it possible for authenticated attackers with subscriber level permissions and above to inject malicious web scripts into a page that execute whenever a user accesses that page.
Affected products
- cloughit Async JavaScript: before 2.20.02.27 — fixed in 2.20.02.27
How to fix
Upgrade to a fixed version: cloughit Async JavaScript 2.20.02.27. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/blog/2020/02/site-takeover-campaign-exploits-multiple-zero-day-vulnerabilities/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b133888c-7673-4796-917c-486bff1b6b12?source=cve
Get alerted when CVE-2020-36854 or the next vulnerability affects your stack