What’s Vulnerable › Vulnerabilities
CVE-2020-37287: Vyper before 0.2.6 Call Stack Corruption via Complex Type Function Arguments
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-28
- Weakness: CWE-131
Description
Vyper before 0.2.6 contains a call stack corruption vulnerability that causes incorrect function outputs when complex types with non-base members are passed as arguments. Contracts passing multi-dimensional arrays or structs to internal or external functions receive corrupted values because the compiler assumed each subtype size is 32.
Affected products
- Pypi Vyper: before 0.2.6; 0.1.0b1, 0.1.0b10, 0.1.0b11, 0.1.0b12, 0.1.0b13, 0.1.0b14 (+16) — fixed in 0.2.6
- vyperlang vyper: before 0.2.6 — fixed in 0.2.6
How to fix
Upgrade to a fixed version: Pypi Vyper 0.2.6; vyperlang vyper 0.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/security/advisories/GHSA-4v7v-gqf9-ww2g
- https://www.vulncheck.com/advisories/vyper-before-0.2.6-call-stack-corruption-via-complex-type-function-arguments
Get alerted when CVE-2020-37287 or the next vulnerability affects your stack