What’s Vulnerable › Vulnerabilities
CVE-2020-3757
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-13 · updated 2026-06-17
- Weakness: CWE-843
Description
Adobe Flash Player versions 32.0.0.321 and earlier, 32.0.0.314 and earlier, 32.0.0.321 and earlier, and 32.0.0.255 and earlier have a type confusion vulnerability. Successful exploitation could lead to arbitrary code execution.
Affected products
- Adobe Flash Player 24.0.0.186 and earlier.: before 32.0.0.321; before 32.0.0.314; through 32.0.0.321; through 32.0.0.255 — fixed in 32.0.0.314, 32.0.0.321
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Workstation: 6.0
How to fix
Upgrade to a fixed version: Adobe Flash Player 24.0.0.186 and earlier. 32.0.0.314, 32.0.0.321. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2020:0513
- https://helpx.adobe.com/security/products/flash-player/apsb20-06.html
- https://security.gentoo.org/glsa/202003-61
- https://access.redhat.com/errata/RHSA-2020:0513
- https://helpx.adobe.com/security/products/flash-player/apsb20-06.html
- https://security.gentoo.org/glsa/202003-61
Get alerted when CVE-2020-3757 or the next vulnerability affects your stack