What’s Vulnerable › Vulnerabilities
CVE-2020-3810
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-05-15 · updated 2026-06-17
- Weakness: CWE-20
Description
Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.10, 20.04
- Debian apt: before 2.1.2 — fixed in 2.1.2
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 32
How to fix
Upgrade to a fixed version: Debian apt 2.1.2. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/bugs/1878177
- https://github.com/Debian/apt/issues/111
- https://lists.debian.org/debian-security-announce/2020/msg00089.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U4PEH357MZM2SUGKETMEHMSGQS652QHH/
- https://salsa.debian.org/apt-team/apt/-/commit/dceb1e49e4b8e4dadaf056be34088b415939cda6
- https://tracker.debian.org/news/1144109/accepted-apt-212-source-into-unstable/
- https://usn.ubuntu.com/4359-1/
- https://usn.ubuntu.com/4359-2/
- https://bugs.launchpad.net/bugs/1878177
- https://github.com/Debian/apt/issues/111
- https://lists.debian.org/debian-security-announce/2020/msg00089.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U4PEH357MZM2SUGKETMEHMSGQS652QHH/
Get alerted when CVE-2020-3810 or the next vulnerability affects your stack