What’s Vulnerable › Vulnerabilities
CVE-2020-3944
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-19 · updated 2026-06-17
- Weakness: CWE-287
Description
vRealize Operations for Horizon Adapter (6.7.x prior to 6.7.1 and 6.6.x prior to 6.6.1) has an improper trust store configuration leading to authentication bypass. An unauthenticated remote attacker who has network access to vRealize Operations, with the Horizon Adapter running, may be able to bypass Adapter authentication.
Affected products
- VMware vRealize Operations: from 6.6.0 before 6.6.1; from 6.7.0 before 6.7.1 — fixed in 6.6.1, 6.7.1
- VMware vRealize Operations: from 6.7.x prior through 6.7.1; from 6.6.x prior through 6.6.1
How to fix
Upgrade to a fixed version: VMware vRealize Operations 6.6.1, 6.7.1. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2020-0003.html
- https://www.vmware.com/security/advisories/VMSA-2020-0003.html
Get alerted when CVE-2020-3944 or the next vulnerability affects your stack