What’s Vulnerable › Vulnerabilities
CVE-2020-3947
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-16 · updated 2026-06-17
- Weakness: CWE-416
Description
VMware Workstation (15.x before 15.5.2) and Fusion (11.x before 11.5.2) contain a use-after vulnerability in vmnetdhcp. Successful exploitation of this issue may lead to code execution on the host from the guest or may allow attackers to create a denial-of-service condition of the vmnetdhcp service running on the host machine.
Affected products
- VMware Fusion: from 11.0.0 (excl.) before 11.5.2 — fixed in 11.5.2
- VMware Workstation: from 15.0.0 before 15.5.2 — fixed in 15.5.2
- VMware Fusion: 11.x before 11.5.2
- VMware Workstation: 15.x before 15.5.2
How to fix
Upgrade to a fixed version: VMware Fusion 11.5.2; VMware Workstation 15.5.2. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2020-0004.html
- https://www.vmware.com/security/advisories/VMSA-2020-0004.html
Get alerted when CVE-2020-3947 or the next vulnerability affects your stack