What’s Vulnerable › Vulnerabilities
CVE-2020-3950: VMware Multiple Products Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 7.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-17 · updated 2026-06-17
- Weakness: CWE-269
Description
VMware Fusion (11.x before 11.5.2), VMware Remote Console for Mac (11.x and prior before 11.0.1) and Horizon Client for Mac (5.x and prior before 5.4.0) contain a privilege escalation vulnerability due to improper use of setuid binaries. Successful exploitation of this issue may allow attackers with normal user privileges to escalate their privileges to root on the system where Fusion, VMRC or Horizon Client is installed.
Affected products
- VMware Fusion: from 11.0.0 before 11.5.2 — fixed in 11.5.2
- VMware Horizon Server: from 5.0.0 before 5.4.0 — fixed in 5.4.0
- VMware Remote Console: from 11.0.0 before 11.0.1 — fixed in 11.0.1
- VMware Fusion, VMware Remote Console for Mac and Horizon Client for Mac: VMware Fusion (11.x before 11.5.2), VMware Remote Console for Mac (11.x and prior before 11.0.1) and Horizon Client for Mac (5.x and prior before 5.4.0)
How to fix
Upgrade to a fixed version: VMware Fusion 11.5.2; VMware Horizon Server 5.4.0; VMware Remote Console 11.0.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/156843/VMware-Fusion-11.5.2-Privilege-Escalation.html
- http://packetstormsecurity.com/files/157079/VMware-Fusion-USB-Arbitrator-Setuid-Privilege-Escalation.html
- https://www.vmware.com/security/advisories/VMSA-2020-0005.html
- http://packetstormsecurity.com/files/156843/VMware-Fusion-11.5.2-Privilege-Escalation.html
- http://packetstormsecurity.com/files/157079/VMware-Fusion-USB-Arbitrator-Setuid-Privilege-Escalation.html
- https://www.vmware.com/security/advisories/VMSA-2020-0005.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2020-3950
Get alerted when CVE-2020-3950 or the next vulnerability affects your stack