What’s Vulnerable › Vulnerabilities

CVE-2020-3956

Description

VMware Cloud Director 10.0.x before 10.0.0.2, 9.7.0.x before 9.7.0.5, 9.5.0.x before 9.5.0.6, and 9.1.0.x before 9.1.0.4 do not properly handle input leading to a code injection vulnerability. An authenticated actor may be able to send malicious traffic to VMware Cloud Director which may lead to arbitrary remote code execution. This vulnerability can be exploited through the HTML5- and Flex-based UIs, the API Explorer interface and API access.

Affected products

How to fix

Upgrade to a fixed version: VMware Cloud Director 10.0.0.2, 9.1.0.4, 9.5.0.6, 9.7.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-3956 or the next vulnerability affects your stack