What’s Vulnerable › Vulnerabilities
CVE-2020-3969
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-24 · updated 2026-06-17
- Weakness: CWE-193
Description
VMware ESXi (7.0 before ESXi_7.0.0-1.20.16321839, 6.7 before ESXi670-202004101-SG and 6.5 before ESXi650-202005401-SG), Workstation (15.x before 15.5.5), and Fusion (11.x before 11.5.5) contain an off-by-one heap-overflow vulnerability in the SVGA device. A malicious actor with local access to a virtual machine with 3D graphics enabled may be able to exploit this vulnerability to execute code on the hypervisor from a virtual machine. Additional conditions beyond the attacker's control must be present for exploitation to be possible.
Affected products
- VMware Cloud Foundation: from 3.0 before 3.10; from 4.0.0 before 4.0.1 — fixed in 3.10, 4.0.1
- VMware ESXi: 6.5-650-201701001, 6.5-650-201703001, 6.5-650-201703002, 6.5-650-201704001, 6.5-650-201707101, 6.5-650-201707102 (+167); 6.5, 6.7, 7.0.0
- VMware Fusion: from 11.0.0 before 11.5.5 — fixed in 11.5.5
- VMware Workstation: from 15.0.0 before 15.5.5 — fixed in 15.5.5
- VMware ESXi: 7.0 before ESXi_7.0.0-1.20.16321839, 6.7 before ESXi670-202004101-SG, 6.5 before ESXi650-202005401-SG
- VMware Fusion: 11.x before 11.5.5
- VMware Workstation: 15.x before 15.5.5
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 3.10, 4.0.1; VMware Fusion 11.5.5; VMware Workstation 15.5.5. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2020-0015.html
- https://www.zerodayinitiative.com/advisories/ZDI-20-786/
- https://www.vmware.com/security/advisories/VMSA-2020-0015.html
- https://www.zerodayinitiative.com/advisories/ZDI-20-786/
Get alerted when CVE-2020-3969 or the next vulnerability affects your stack